re = /\([^\]()*(?:USCS|§)[^\]()*)/i
str = ' asdasdas asdsadsadsa sadasdsadsadsadsa(RSVP dog) [§111)] [cat] (§111 asdasadsa) asdasdsadsadsadsadsadsadsadsa asdasd asdsadsadsadsadsadsadsadsadsadsadsasdadsasadsadsadsadsadsadsadsasad'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end