import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\([^\\]()*(?:USCS|§)[^\\]()*)";
final String string = " asdasdas asdsadsadsa sadasdsadsadsadsa(RSVP dog) [§111)] [cat] (§111 asdasadsa) asdasdsadsadsadsadsadsadsadsa asdasd asdsadsadsadsadsadsadsadsadsadsadsasdadsasadsadsadsadsadsadsadsasad";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}