package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(\+88)?01[3-9]\d{8}$`)
var str = `01300000000`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}