$re = '/^(\+88)?01[3-9]\d{8}$/';
$str = '01300000000';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);