const regex = /^(\+88)?01[3-9]\d{8}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\+88)?01[3-9]\\d{8}$', '')
const str = `01300000000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}