re = /(?:function\s+\w+\s*)\((.*)\)(?:(?:(?:\s*:\s*)(\w+.*)))/
str = 'private static function parse(
strJson:String,
iStart:Int,
iEnd:Int) : Map<String,String>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end