import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bsource(?::|=)(\")?(?(1)(?P<value1>[^\"]+)\"|(?P<value2>\\S+))";
final String string = "... source=\"source name with quotes - special characters also\" ...\n\n"
+ "... source=source_name_without_quotes_with_special-characters* ...\n\n"
+ "... source=\"source_name_with_quotes_no_spaces-*\" ...";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}