// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\bsource(?::|=)(")?(?(1)(?P<value1>[^"]+)"|(?P<value2>\S+))"#).unwrap();
let string = "... source=\"source name with quotes - special characters also\" ...
... source=source_name_without_quotes_with_special-characters* ...
... source=\"source_name_with_quotes_no_spaces-*\" ...";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}