import re
regex = re.compile(r"\bsource(?::|=)(\")?(?(1)(?P<value1>[^\"]+)\"|(?P<value2>\S+))", flags=re.MULTILINE)
test_str = ("... source=\"source name with quotes - special characters also\" ...\n\n"
"... source=source_name_without_quotes_with_special-characters* ...\n\n"
"... source=\"source_name_with_quotes_no_spaces-*\" ...")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")