package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(° ?)?[0-9]+(\.[0-9]+)? ?°? ?[fF]\b`)
var str = `23°F
23° F
23°f
23° F
°23f
°23F
23.3 F
23.3f
212°F
° 27 f
27 ° f
28 °F
29 °f
There are 10 flies on the wall and this sentence must not match.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}