const regex = /(° ?)?[0-9]+(\.[0-9]+)? ?°? ?[fF]\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(° ?)?[0-9]+(\\.[0-9]+)? ?°? ?[fF]\\b', 'gm')
const str = `23°F
23° F
23°f
23° F
°23f
°23F
23.3 F
23.3f
212°F
° 27 f
27 ° f
28 °F
29 °f
There are 10 flies on the wall and this sentence must not match.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}