// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(° ?)?[0-9]+(\.[0-9]+)? ?°? ?[fF]\b").unwrap();
let string = "23°F
23° F
23°f
23° F
°23f
°23F
23.3 F
23.3f
212°F
° 27 f
27 ° f
28 °F
29 °f
There are 10 flies on the wall and this sentence must not match.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}