using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<td class=""name"">\n\s+<a[^>]+>(.*)(?=<\/a>)";
string input = @"<header class=""ipl-header"">
<div class=""ipl-header__content"">
<h4 name=""producers"" id=""producers"" class=""ipl-header__content ipl-list-title"">
Produced by
</h4>
</div>
<a class=""ipl-header__edit-link"" href=""https://contribute.imdb.com/updates?update=tt2527336:producers"">Edit</a>
</header>
<table class=""subpage_data spFirst crew_list"">
<tbody>
<tr class=""even"">
<td class=""name"">
<a href=""/name/nm0009190/?ref_=tt_rv""
>J.J. Abrams</a>
</td>
<td>...</td>
<td>executive producer</td>
</tr>
<tr class=""odd"">
<td class=""name"">
<a href=""/name/nm0027297/?ref_=tt_rv""
>Pippa Anderson</a>
</td>
<td>...</td>
<td>co-producer</td>
</tr>
</tbody>
</table>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}