use strict;
my $str = '<header class="ipl-header">
<div class="ipl-header__content">
<h4 name="producers" id="producers" class="ipl-header__content ipl-list-title">
Produced by
</h4>
</div>
<a class="ipl-header__edit-link" href="https://contribute.imdb.com/updates?update=tt2527336:producers">Edit</a>
</header>
<table class="subpage_data spFirst crew_list">
<tbody>
<tr class="even">
<td class="name">
<a href="/name/nm0009190/?ref_=tt_rv"
>J.J. Abrams</a>
</td>
<td>...</td>
<td>executive producer</td>
</tr>
<tr class="odd">
<td class="name">
<a href="/name/nm0027297/?ref_=tt_rv"
>Pippa Anderson</a>
</td>
<td>...</td>
<td>co-producer</td>
</tr>
</tbody>
</table>';
my $regex = qr/<td class="name">\n\s+<a[^>]+>(.*)(?=<\/a>)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}