#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^ecp\.eset\.systems|(?:edf|h(?:[1,3,5]\-arse0[1,2]|5\-arse0[3,4]|1\-edfspy02)\-v)\.eset\.com$"
Local $sString = "edf.eset.com" & @CRLF & _
"h1-arse01-v.eset.com" & @CRLF & _
"h1-arse02-v.eset.com" & @CRLF & _
"" & @CRLF & _
"h3-arse01-v.eset.com" & @CRLF & _
"h3-arse02-v.eset.com" & @CRLF & _
"" & @CRLF & _
"h5-arse01-v.eset.com" & @CRLF & _
"h5-arse02-v.eset.com" & @CRLF & _
"h5-arse03-v.eset.com" & @CRLF & _
"h5-arse04-v.eset.com" & @CRLF & _
"" & @CRLF & _
"h1-edfspy02-v.eset.com" & @CRLF & _
"h1-edfspy02-v.eset.com" & @CRLF & _
"ecp.eset.systems" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")