package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^ecp\.eset\.systems|(?:edf|h(?:[1,3,5]\-arse0[1,2]|5\-arse0[3,4]|1\-edfspy02)\-v)\.eset\.com$`)
var str = `edf.eset.com
h1-arse01-v.eset.com
h1-arse02-v.eset.com
h3-arse01-v.eset.com
h3-arse02-v.eset.com
h5-arse01-v.eset.com
h5-arse02-v.eset.com
h5-arse03-v.eset.com
h5-arse04-v.eset.com
h1-edfspy02-v.eset.com
h1-edfspy02-v.eset.com
ecp.eset.systems
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}