import re
regex = re.compile(r"^ecp\.eset\.systems|(?:edf|h(?:[1,3,5]\-arse0[1,2]|5\-arse0[3,4]|1\-edfspy02)\-v)\.eset\.com$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("edf.eset.com\n"
"h1-arse01-v.eset.com\n"
"h1-arse02-v.eset.com\n\n"
"h3-arse01-v.eset.com\n"
"h3-arse02-v.eset.com\n\n"
"h5-arse01-v.eset.com\n"
"h5-arse02-v.eset.com\n"
"h5-arse03-v.eset.com\n"
"h5-arse04-v.eset.com\n\n"
"h1-edfspy02-v.eset.com\n"
"h1-edfspy02-v.eset.com\n"
"ecp.eset.systems\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")