# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?<!\\/dist\\/)(.*)\\/(.*?\.css)$/\/dist\/$2/gim;t' <<< "/internal/benefitlist/pmlweb.min.css
/internal/benefitlist
/dist/pmlweb.min.css
dist/pmlweb.min.css
/pmlweb.min.css
/dist/a.css
"