import re
regex = re.compile(r"^(?<!\/dist\/)(.*)\/(.*?\.css)$", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("/internal/benefitlist/pmlweb.min.css\n"
"/internal/benefitlist\n"
"/dist/pmlweb.min.css\n"
"dist/pmlweb.min.css\n"
"/pmlweb.min.css\n"
"/dist/a.css\n")
subst = "/dist/$2"
result = regex.sub(subst, test_str)
if result:
print(result)