use strict;
my $str = '/internal/benefitlist/pmlweb.min.css
/internal/benefitlist
/dist/pmlweb.min.css
dist/pmlweb.min.css
/pmlweb.min.css
/dist/a.css
';
my $regex = qr/^(?<!\/dist\/)(.*)\/(.*?\.css)$/imp;
my $subst = '/dist/$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";