# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\[קטגוריה:איןטקסט:שירים\])/[קטגוריה:איןטונס: אווטארים]/gm;t' <<< "תוכן הערך
[[קטגוריה:קטגוריה]][[קטגוריה:איןטקסט:שירים]][[קטגוריה:איןטקסט: בלה בלה בלה]]"