use strict;
my $str = 'תוכן הערך
[[קטגוריה:קטגוריה]][[קטגוריה:איןטקסט:שירים]][[קטגוריה:איןטקסט: בלה בלה בלה]]';
my $regex = qr/(\[קטגוריה:איןטקסט:שירים\])/mp;
my $subst = '[קטגוריה:איןטונס: אווטארים]';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";