use strict;
my $str = 'RT @iamkhiofficial2323: #lahore #LahoreBlasts : #punjabgovt 9 #dead. 20 #injured. https://t.co/UU7doEtTmZ #pray #unite #notgivingup RT @iamkhiofficial2323
RT @iamkhiofficial2323';
my $regex = qr/RT(\A|\s)@(\w)+/p;
my $subst = '<label class="">$0</label>';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";