const regex = /^(B2B_([0-9A-Z]+))?(_([A-Za-z0-9]+)(?:_[A-Za-z0-9]+)*)?\.jpg$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(B2B_([0-9A-Z]+))?(_([A-Za-z0-9]+)(?:_[A-Za-z0-9]+)*)?\\.jpg$', 'gm')
const str = `B2B_1111108A20.jpg
B2B_1111108A20_1.jpg
B2B_1111108A20_2_S.jpg
B2B_1111108A20_3_ST.jpg`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}