$re = '/^(B2B_([0-9A-Z]+))?(_([A-Za-z0-9]+)(?:_[A-Za-z0-9]+)*)?\.jpg$/m';
$str = 'B2B_1111108A20.jpg
B2B_1111108A20_1.jpg
B2B_1111108A20_2_S.jpg
B2B_1111108A20_3_ST.jpg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);