import re
regex = re.compile(r"^(B2B_([0-9A-Z]+))?(_([A-Za-z0-9]+)(?:_[A-Za-z0-9]+)*)?\.jpg$", flags=re.MULTILINE)
test_str = ("B2B_1111108A20.jpg\n"
"B2B_1111108A20_1.jpg\n"
"B2B_1111108A20_2_S.jpg\n"
"B2B_1111108A20_3_ST.jpg")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")