using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d+[A-z_][A-z_0-9]*|[_A-z][A-z0-9]*)$";
string input = @"a
ab
1
1a
_
1a345555
__1xD
1234";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}