$re = '/^(\d+[A-z_][A-z_0-9]*|[_A-z][A-z0-9]*)$/m';
$str = 'a
ab
1
1a
_
1a345555
__1xD
1234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);