// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\d+[A-z_][A-z_0-9]*|[_A-z][A-z0-9]*)$").unwrap();
let string = "a
ab
1
1a
_
1a345555
__1xD
1234";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}