# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^((?:\d,){2})((?:\d,))((?:\d,?)*)/\1\3/mg;t' <<< "1,2,3,4,5,6,7"