const regex = /^((?:\d,){2})((?:\d,))((?:\d,?)*)/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?:\\d,){2})((?:\\d,))((?:\\d,?)*)', 'mg')
const str = `1,2,3,4,5,6,7`;
const subst = `\1\3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);