#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\(\d+\) (.+)\n(\([A-Z]\).*?)। Ans \(([A-Z])\)"
Local $sString = "(1) Capital of Bangladesh is-" & @CRLF & _
"(A) Dhaka (B) Rangpur (C) Chittagong (D) Comilla। Ans (A) Dhaka" & @CRLF & _
"(2) Largest city of Bangladesh is-" & @CRLF & _
"(A) Mirpur (B) Rangpur (C) Chittagong (D) Comilla। Ans (C) Chittagong" & @CRLF & _
"(3) Smallest city of Bangladesh is-" & @CRLF & _
"(A) Dhaka (B) Rangpur (C) Chittagong (D) Meherpur। Ans (B) Rangpur"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")