import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\(\\d+\\) (.+)\\n(\\([A-Z]\\).*?)। Ans \\(([A-Z])\\)";
final String string = "(1) Capital of Bangladesh is-\n"
+ "(A) Dhaka (B) Rangpur (C) Chittagong (D) Comilla। Ans (A) Dhaka\n"
+ "(2) Largest city of Bangladesh is-\n"
+ "(A) Mirpur (B) Rangpur (C) Chittagong (D) Comilla। Ans (C) Chittagong\n"
+ "(3) Smallest city of Bangladesh is-\n"
+ "(A) Dhaka (B) Rangpur (C) Chittagong (D) Meherpur। Ans (B) Rangpur";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}