# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\(\d+\) (.+)\n(\([A-Z]\).*?)। Ans \(([A-Z])\)"
test_str = ("(1) Capital of Bangladesh is-\n"
"(A) Dhaka (B) Rangpur (C) Chittagong (D) Comilla। Ans (A) Dhaka\n"
"(2) Largest city of Bangladesh is-\n"
"(A) Mirpur (B) Rangpur (C) Chittagong (D) Comilla। Ans (C) Chittagong\n"
"(3) Smallest city of Bangladesh is-\n"
"(A) Dhaka (B) Rangpur (C) Chittagong (D) Meherpur। Ans (B) Rangpur")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.