using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".([0-9]{4,5}).";
string input = @"pe01058pr04 pe1234pr03";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}