$re = '/.([0-9]{4,5})./m';
$str = 'pe01058pr04 pe1234pr03';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);