package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).([0-9]{4,5}).`)
var str = `pe01058pr04 pe1234pr03`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}