// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[#]{1,5}\s[\w\s]*(?:\*[\w\s]+\*|(?:\*\*[\w\s]+\*\*))").unwrap();
let string = "## *test*
# ** this is some **
# some other** this is some **
##### this is ok";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}