#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(.+?)\|.*[^ ]\K *\r?\n\1"
Local $sString = "apple|pear " & @CRLF & _
"apple|quince " & @CRLF & _
"apple cider|juice" & @CRLF & _
"banana|plantain" & @CRLF & _
"cherry|cheerful, crimson" & @CRLF & _
"cherry|ruddy" & @CRLF & _
"cherry|cerise" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)