re = /^(.+?)\|.*[^ ]\K *\r?\n\1/m
str = 'apple|pear
apple|quince
apple cider|juice
banana|plantain
cherry|cheerful, crimson
cherry|ruddy
cherry|cerise
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result