using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?:\w[\w-]{0,61}\.)*)(\w[\w-]{0,61}\.[a-z]{2,62})$";
string substitution = @"$2";
string input = @"sites.example.com
m.example.com
www.example.com
ww2.example.com
mail.example.com
blog.example.com
shop.example.com
cdn.example.com
api.example.com
1.example.com
example.com
section.sub-domain.example.com";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}