const regex = /^((?:\w[\w-]{0,61}\.)*)(\w[\w-]{0,61}\.[a-z]{2,62})$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?:\\w[\\w-]{0,61}\\.)*)(\\w[\\w-]{0,61}\\.[a-z]{2,62})$', 'gmi')
const str = `sites.example.com
m.example.com
www.example.com
ww2.example.com
mail.example.com
blog.example.com
shop.example.com
cdn.example.com
api.example.com
1.example.com
example.com
section.sub-domain.example.com`;
const subst = `$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);