package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^((?:\w[\w-]{0,61}\.)*)(\w[\w-]{0,61}\.[a-z]{2,62})$`)
var str = `sites.example.com
m.example.com
www.example.com
ww2.example.com
mail.example.com
blog.example.com
shop.example.com
cdn.example.com
api.example.com
1.example.com
example.com
section.sub-domain.example.com`
var substitution = "$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}