const regex = /^(?=\d{9}$)0*[1-9]*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=\\d{9}$)0*[1-9]*$', 'gm')
const str = `000001111
000000010
000000000
001215341
165160000
0165168546`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}