$re = '/^(?=\d{9}$)0*[1-9]*$/m';
$str = '000001111
000000010
000000000
001215341
165160000
0165168546';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);