re = /^(?=\d{9}$)0*[1-9]*$/m
str = '000001111
000000010
000000000
001215341
165160000
0165168546'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end