#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\*{3}.*?)(?:\s*\.{3}DONE=>.*)?(\*{3})$"
Local $sString = "*** HEDAL - 2021 COMPLETE - MF - 03-01-2021...DONE=> AWR 02-2021, BUI 02-2021, PQL 02-2021, NCC 02-2021, ***" & @CRLF & _
"*** HEDAL - 2021 COMPLETE - MF - 03-01-2021...DONE=> NCC 03-2021, ***" & @CRLF & _
"*** HEDAL - NCC? - MF - 03-01-2021 ***" & @CRLF & _
"*** HEDAL - CSP? - MF - 03-02-2021 ...DONE=> PPSC 08-2020, ***" & @CRLF & _
"*** HEDAL - WELL CHALI? LSPC? CSP? - MF - 03-02-2021 ***" & @CRLF & _
"*** HEDAL - AWR? PHQ? NCC? - MF - 03-05-2021 ...DONE=> BUI 09-2020, ***" & @CRLF & _
"*** HEDAL - 2021 COMPLETE - MF - 03-05-2021...DONE=> NWC 02-2021, BUI 02-2021, PQL 02-2021, NCC 02-2021, ***" & @CRLF & _
"*** HEDAL - NWC? PQL? NCC? - MF - 03-05-2021 ...DONE=> BUI 12-2020, ***" & @CRLF & _
"*** HEDAL - CHALI? NCC? - MF - 03-06-2021 ***" & @CRLF & _
"*** HEDAL - CHL? - MF - 03-06-2021 ...DONE=> NWC 02-2021, BUI 02-2021, PQL 02-2021, NCC 02-2021, ***" & @CRLF & _
"*** HEDAL - 2021 COMPLETE - MF - 03-08-2021...DONE=> CHALI 01-2021, NCC 01-2021, ***" & @CRLF & _
"*** HEDAL - 2021 COMPLETE - MF - 03-02-2021...DONE=> NWC 03-2021, CHL 03-2021, BUI 03-2021, PQL 03-2021, TOBA 03-2021, ***" & @CRLF & _
"*** HEDAL - WELL CHILD VISIT? WCC? - MF - 03-06-2021 ***" & @CRLF & _
"*** HEDAL -ExAMING? - AZ - 03-01-2021 ...DONE=> AAC 03-2021, LAL 03-2021, MICA 03-2021, BUI 03-2021, TOBA 03-2021, ***"
Local $sSubst = "$1 $2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)