# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\*{3}.*?)(?:\s*\.{3}DONE=>.*)?(\*{3})$"
test_str = ("*** HEDAL - 2021 COMPLETE - MF - 03-01-2021...DONE=> AWR 02-2021, BUI 02-2021, PQL 02-2021, NCC 02-2021, ***\n"
"*** HEDAL - 2021 COMPLETE - MF - 03-01-2021...DONE=> NCC 03-2021, ***\n"
"*** HEDAL - NCC? - MF - 03-01-2021 ***\n"
"*** HEDAL - CSP? - MF - 03-02-2021 ...DONE=> PPSC 08-2020, ***\n"
"*** HEDAL - WELL CHALI? LSPC? CSP? - MF - 03-02-2021 ***\n"
"*** HEDAL - AWR? PHQ? NCC? - MF - 03-05-2021 ...DONE=> BUI 09-2020, ***\n"
"*** HEDAL - 2021 COMPLETE - MF - 03-05-2021...DONE=> NWC 02-2021, BUI 02-2021, PQL 02-2021, NCC 02-2021, ***\n"
"*** HEDAL - NWC? PQL? NCC? - MF - 03-05-2021 ...DONE=> BUI 12-2020, ***\n"
"*** HEDAL - CHALI? NCC? - MF - 03-06-2021 ***\n"
"*** HEDAL - CHL? - MF - 03-06-2021 ...DONE=> NWC 02-2021, BUI 02-2021, PQL 02-2021, NCC 02-2021, ***\n"
"*** HEDAL - 2021 COMPLETE - MF - 03-08-2021...DONE=> CHALI 01-2021, NCC 01-2021, ***\n"
"*** HEDAL - 2021 COMPLETE - MF - 03-02-2021...DONE=> NWC 03-2021, CHL 03-2021, BUI 03-2021, PQL 03-2021, TOBA 03-2021, ***\n"
"*** HEDAL - WELL CHILD VISIT? WCC? - MF - 03-06-2021 ***\n"
"*** HEDAL -ExAMING? - AZ - 03-01-2021 ...DONE=> AAC 03-2021, LAL 03-2021, MICA 03-2021, BUI 03-2021, TOBA 03-2021, ***")
subst = "$1 $2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.