#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\.?(?:(?:\d{1,3}[,. ])*\d{1,3}(?:\.\d{2})?|\d+\.\d+|\d+)\.?$"
Local $sString = "1,000" & @CRLF & _
"1000.00" & @CRLF & _
"1,000,000.00" & @CRLF & _
"2.000.000,00" & @CRLF & _
"123748" & @CRLF & _
"4 294 967 295,000" & @CRLF & _
"0.24" & @CRLF & _
".24" & @CRLF & _
"24" & @CRLF & _
"24."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")