package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\.?(?:(?:\d{1,3}[,. ])*\d{1,3}(?:\.\d{2})?|\d+\.\d+|\d+)\.?$`)
var str = `1,000
1000.00
1,000,000.00
2.000.000,00
123748
4 294 967 295,000
0.24
.24
24
24.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}